Payment Request API
Incident Report for Finto Platform Status SANDBOX
Resolved
Incident resolved
Posted Sep 14, 2024 - 05:16 UTC
Identified
Service is temporary unavailable due to technical reasons.
Posted Sep 14, 2024 - 05:15 UTC
This incident affected: Payment Request API.