Remittance API
Incident Report for Finto Platform Status SANDBOX
Resolved
Incident resolved
Posted Sep 06, 2024 - 03:47 UTC
Identified
Service is temporary unavailable due to technical reasons.
Posted Sep 06, 2024 - 03:46 UTC
This incident affected: Remittance API.