Scoring API
Incident Report for Finto Platform Status SANDBOX
Resolved
Incident resolved
Posted Sep 15, 2024 - 06:59 UTC
Identified
Service is temporary unavailable due to technical reasons.
Posted Sep 15, 2024 - 06:58 UTC
This incident affected: Credit Score API.