Scoring API
Incident Report for Finto Platform Status SANDBOX
Resolved
Incident resolved
Posted Sep 09, 2024 - 12:42 UTC
Identified
Service is temporary unavailable due to technical reasons.
Posted Sep 09, 2024 - 12:41 UTC
This incident affected: Credit Score API.